Odoo中文社区可以通过以下三个域名访问:shine-it.net , odoocn.org,odoo.net.cn

原论坛用户的基本信息和发帖这里都予以保留,请注意:原论坛用户无需重新注册新用户,但是您的密码需要重置

开发人员可以登录gitter讨论组: http://gitter.im/odoo-china/Talk, 需要github账号

如果您登录系统碰到问题,请在微信公众号留言:

Openerp不能建立数据库 求助!!



  • 本来在机器上安装了6.0.1,但是备份数据库的时候出错,查到论坛上有一个帖子谈到这个问题,但是却找不到帖子里面说的那个bin目录下的那个文件,问题无法解决。后来看到openerp网站上有更新,最新版本是6.0.2,所以下载 allinone,在windows上重新安装。
    安装之前已经卸载了6.0.1的所有组件,包括数据库,但是装完6.0.2后,发现无法创建数据库,而且语言选项那里只有英文,其他语言都不见了。本来以为是6.0.2的问题,所以又卸载掉,装回6.0.1,但是问题一样,语言选项还是只有英文,数据库无法建立,我使用的是密码:admin,默认未作修改。
    请大家帮忙看看,这个到底是什么问题呢?
    谢谢!



  • 本来在机器上安装了6.0.1,但是备份数据库的时候出错,查到论坛上有一个帖子谈到这个问题,但是却找不到帖子里面说的那个bin目录下的那个文件,问题无法解决。后来看到openerp网站上有更新,最新版本是6.0.2,所以下载 allinone,在windows上重新安装。
    安装之前已经卸载了6.0.1的所有组件,包括数据库,但是装完6.0.2后,发现无法创建数据库,而且语言选项那里只有英文,其他语言都不见了。本来以为是6.0.2的问题,所以又卸载掉,装回6.0.1,但是问题一样,语言选项还是只有英文,数据库无法建立,我使用的是密码:admin,默认未作修改。
    请大家帮忙看看,这个到底是什么问题呢?
    谢谢!



  • 在系统日志中发现如下错误信息:
    日志名称:          Application
    来源:            openerp-server-6.0
    日期:            2011/4/3 21:40:41
    事件 ID:        3
    任务类别:          无
    级别:            错误
    关键字:          经典
    用户:            暂缺
    计算机:          jerry-PC
    描述:
    无法找到来自源 openerp-server-6.0 的事件 ID 3 的描述。本地计算机上未安装引发此事件的组件,或者安装已损坏。可以安装或修复本地计算机上的组件。

    如果该事件产生于另一台计算机,则必须在该事件中保存显示信息。

    以下是包含在事件中的信息:

      File "win32serviceutil.pyc", line 805, in SvcRun
      File "OpenERPServerService.pyc", line 88, in SvcDoRun
    <type 'exceptions.SystemExit'>
    OpenERP Server check: server not running, check the logfile for more info

    事件 Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="openerp-server-6.0" />
        <EventID Qualifiers="49152">3</EventID>
        <Level>2</Level>
        <Task>0</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2011-04-03T13:40:41.000000000Z" />
        <EventRecordID>2105</EventRecordID>
        <Channel>Application</Channel>
        <Computer>jerry-PC</Computer>
        <Security />
      </System>
      <EventData>
        <Data>  File "win32serviceutil.pyc", line 805, in SvcRun
      File "OpenERPServerService.pyc", line 88, in SvcDoRun</Data>
        <Data>&lt;type 'exceptions.SystemExit'&gt;</Data>
        <Data>OpenERP Server check: server not running, check the logfile for more info</Data>
      </EventData>
    </Event>
    Server没有启动,请问这是什么原因呢?谢谢



  • conf文件我也看过了,几个重要的信息应该都是正确的,Path路径也已经加上了,到底是什么原因导致的呢?
    db_password =openpgpwd
    db_name =    (这里原来是否false,改成空也不行)
    db_port =5432
    db_user =openpg
    db_host =localhost
    root_path = C:\Program Files\OpenERP 6.0\Server



  • 问题解决了,主要的原因应该是这里没设置,原始是false,奇怪~~
    pg_path = C:\Program Files\OpenERP 6.0\PostgreSQL\bin



  • 上面写了这么多,真是瞎折腾…………最正确的方法是,安装完后重启电脑!!!!!!!!!



  • 嗯... 是否重启电脑不重要..

    重要的是,一定要重启 OE Server 的服务... :)

    经验就是这样瞎折腾出来的.... 慢慢来. 表着急...



  • 版主一说,我才明白为何我重启电脑就可以了,谢谢,知其然并知其所以然,这是一个良好的开始,但是我在linux的安装上还是有问题,发在安装板块了,请版主有时间的话帮忙看看,非常感谢。


登录后回复
 

与 Odoo 中文社区 的连接断开,我们正在尝试重连,请耐心等待