Odoo中文社区可以通过以下三个域名访问:shine-it.net , odoocn.org,odoo.net.cn

原论坛用户的基本信息和发帖这里都予以保留,请注意:原论坛用户无需重新注册新用户,但是您的密码需要重置

开发人员可以登录gitter讨论组: http://gitter.im/odoo-china/Talk, 需要github账号

如果您登录系统碰到问题,请在微信公众号留言:

虽然也装上了,但安装过程提示的一个错误信息,关于libyaml



  • <br />用的是论坛的CenOS脚步安装(在此表示感谢,很好用;虽然也装上了,也能运行,但是过程中提示一下信息,好像是PyYAML没装好,这个重要吗? 我怎么能手动装上?<br /><br />..........<br />Installed /usr/lib/python2.6/site-packages/simplejson-3.3.1-py2.6-linux-i686.egg<br />Searching for pyyaml<br />Reading http://pypi.python.org/simple/pyyaml/<br />Best match: PyYAML 3.10<br />Downloading https://pypi.python.org/packages/source/P/PyYAML/PyYAML-3.10.zip#md5=b1a2b30cdf481da4249c917c3307f129<br />Processing PyYAML-3.10.zip<br />Running PyYAML-3.10/setup.py -q bdist_egg --dist-dir /tmp/easy_install-iU3fhz/PyYAML-3.10/egg-dist-tmp-tiV6ls<br />build/temp.linux-i686-2.6/check_libyaml.c:2:18: 错误:yaml.h:没有那个文件或目录<br />build/temp.linux-i686-2.6/check_libyaml.c: 在函数‘main’中:<br />build/temp.linux-i686-2.6/check_libyaml.c:5: 错误:‘yaml_parser_t’未声明(在此函数内第一次使用)<br />build/temp.linux-i686-2.6/check_libyaml.c:5: 错误:(即使在一个函数内多次出现,每个未声明的标识符在其<br />build/temp.linux-i686-2.6/check_libyaml.c:5: 错误:所在的函数内也只报告一次。)<br />build/temp.linux-i686-2.6/check_libyaml.c:5: 错误:expected ‘;’ before ‘parser’<br />build/temp.linux-i686-2.6/check_libyaml.c:6: 错误:‘yaml_emitter_t’未声明(在此函数内第一次使用)<br />build/temp.linux-i686-2.6/check_libyaml.c:6: 错误:expected ‘;’ before ‘emitter’<br />build/temp.linux-i686-2.6/check_libyaml.c:8: 警告:隐式声明函数‘yaml_parser_initialize’<br />build/temp.linux-i686-2.6/check_libyaml.c:8: 错误:‘parser’未声明(在此函数内第一次使用)<br />build/temp.linux-i686-2.6/check_libyaml.c:9: 警告:隐式声明函数‘yaml_parser_delete’<br />build/temp.linux-i686-2.6/check_libyaml.c:11: 警告:隐式声明函数‘yaml_emitter_initialize’<br />build/temp.linux-i686-2.6/check_libyaml.c:11: 错误:‘emitter’未声明(在此函数内第一次使用)<br />build/temp.linux-i686-2.6/check_libyaml.c:12: 警告:隐式声明函数‘yaml_emitter_delete’<br /><br />libyaml is not found or a compiler error: forcing --without-libyaml<br />(if libyaml is installed correctly, you may need to<br /> specify the option --include-dirs or uncomment and<br /> modify the parameter include_dirs in setup.cfg)<br />zip_safe flag not set; analyzing archive contents...<br />Adding PyYAML 3.10 to easy-install.pth file<br /><br />Installed /usr/lib/python2.6/site-packages/PyYAML-3.10-py2.6-linux-i686.egg<br />Searching for mock<br />Reading http://pypi.python.org/simple/mock/<br />Best match: mock 1.0.1<br />Downloading https://pypi.python.org/packages/source/m/mock/mock-1.0.1.zip#md5=869f08d003c289a97c1a6610faf5e913<br />Processing mock-1.0.1.zip<br />Running mock-1.0.1/setup.py -q bdist_egg --dist-dir /tmp/easy_install-a4kp2y/mock-1.0.1/egg-dist-tmp-ahuSd3<br />warning: no files found matching '.png' under directory 'docs'<br />warning: no files found matching '.css' under directory 'docs'<br />warning: no files found matching '.html' under directory 'docs'<br />warning: no files found matching '.js' under directory 'docs'<br />zip_safe flag not set; analyzing archive contents...<br />Adding mock 1.0.1 to easy-install.pth file<br /><br />Installed /usr/lib/python2.6/site-packages/mock-1.0.1-py2.6.egg<br />Searching for Jinja2<br />Reading http://pypi.python.org/simple/Jinja2/<br />Best match: Jinja2 2.7.1<br /><br />Downloading https://pypi.python.org/packages/source/J/Jinja2/Jinja2-2.7.1.tar.gz#md5=282aed153e69f970d6e76f78ed9d027a<br />Processing Jinja2-2.7.1.tar.gz<br />Running Jinja2-2.7.1/setup.py -q bdist_egg --dist-dir /tmp/easy_install-BXIwji/Jinja2-2.7.1/egg-dist-tmp-wRAOlC<br />warning: no files found matching '' under directory 'custom_fixers'<br />warning: no previously-included files matching '' found under directory 'docs/_build'<br />warning: no previously-included files matching '.pyc' found under directory 'jinja2'<br />warning: no previously-included files matching '.pyc' found under directory 'docs'<br />warning: no previously-included files matching '.pyo' found under directory 'jinja2'<br />warning: no previously-included files matching '.pyo' found under directory 'docs'<br />Adding Jinja2 2.7.1 to easy-install.pth file<br />...................



  • <br />用的是论坛的CenOS脚步安装(在此表示感谢,很好用;虽然也装上了,也能运行,但是过程中提示一下信息,好像是PyYAML没装好,这个重要吗? 我怎么能手动装上?<br /><br />..........<br />Installed /usr/lib/python2.6/site-packages/simplejson-3.3.1-py2.6-linux-i686.egg<br />Searching for pyyaml<br />Reading http://pypi.python.org/simple/pyyaml/<br />Best match: PyYAML 3.10<br />Downloading https://pypi.python.org/packages/source/P/PyYAML/PyYAML-3.10.zip#md5=b1a2b30cdf481da4249c917c3307f129<br />Processing PyYAML-3.10.zip<br />Running PyYAML-3.10/setup.py -q bdist_egg --dist-dir /tmp/easy_install-iU3fhz/PyYAML-3.10/egg-dist-tmp-tiV6ls<br />build/temp.linux-i686-2.6/check_libyaml.c:2:18: 错误:yaml.h:没有那个文件或目录<br />build/temp.linux-i686-2.6/check_libyaml.c: 在函数‘main’中:<br />build/temp.linux-i686-2.6/check_libyaml.c:5: 错误:‘yaml_parser_t’未声明(在此函数内第一次使用)<br />build/temp.linux-i686-2.6/check_libyaml.c:5: 错误:(即使在一个函数内多次出现,每个未声明的标识符在其<br />build/temp.linux-i686-2.6/check_libyaml.c:5: 错误:所在的函数内也只报告一次。)<br />build/temp.linux-i686-2.6/check_libyaml.c:5: 错误:expected ‘;’ before ‘parser’<br />build/temp.linux-i686-2.6/check_libyaml.c:6: 错误:‘yaml_emitter_t’未声明(在此函数内第一次使用)<br />build/temp.linux-i686-2.6/check_libyaml.c:6: 错误:expected ‘;’ before ‘emitter’<br />build/temp.linux-i686-2.6/check_libyaml.c:8: 警告:隐式声明函数‘yaml_parser_initialize’<br />build/temp.linux-i686-2.6/check_libyaml.c:8: 错误:‘parser’未声明(在此函数内第一次使用)<br />build/temp.linux-i686-2.6/check_libyaml.c:9: 警告:隐式声明函数‘yaml_parser_delete’<br />build/temp.linux-i686-2.6/check_libyaml.c:11: 警告:隐式声明函数‘yaml_emitter_initialize’<br />build/temp.linux-i686-2.6/check_libyaml.c:11: 错误:‘emitter’未声明(在此函数内第一次使用)<br />build/temp.linux-i686-2.6/check_libyaml.c:12: 警告:隐式声明函数‘yaml_emitter_delete’<br /><br />libyaml is not found or a compiler error: forcing --without-libyaml<br />(if libyaml is installed correctly, you may need to<br /> specify the option --include-dirs or uncomment and<br /> modify the parameter include_dirs in setup.cfg)<br />zip_safe flag not set; analyzing archive contents...<br />Adding PyYAML 3.10 to easy-install.pth file<br /><br />Installed /usr/lib/python2.6/site-packages/PyYAML-3.10-py2.6-linux-i686.egg<br />Searching for mock<br />Reading http://pypi.python.org/simple/mock/<br />Best match: mock 1.0.1<br />Downloading https://pypi.python.org/packages/source/m/mock/mock-1.0.1.zip#md5=869f08d003c289a97c1a6610faf5e913<br />Processing mock-1.0.1.zip<br />Running mock-1.0.1/setup.py -q bdist_egg --dist-dir /tmp/easy_install-a4kp2y/mock-1.0.1/egg-dist-tmp-ahuSd3<br />warning: no files found matching '.png' under directory 'docs'<br />warning: no files found matching '.css' under directory 'docs'<br />warning: no files found matching '.html' under directory 'docs'<br />warning: no files found matching '.js' under directory 'docs'<br />zip_safe flag not set; analyzing archive contents...<br />Adding mock 1.0.1 to easy-install.pth file<br /><br />Installed /usr/lib/python2.6/site-packages/mock-1.0.1-py2.6.egg<br />Searching for Jinja2<br />Reading http://pypi.python.org/simple/Jinja2/<br />Best match: Jinja2 2.7.1<br /><br />Downloading https://pypi.python.org/packages/source/J/Jinja2/Jinja2-2.7.1.tar.gz#md5=282aed153e69f970d6e76f78ed9d027a<br />Processing Jinja2-2.7.1.tar.gz<br />Running Jinja2-2.7.1/setup.py -q bdist_egg --dist-dir /tmp/easy_install-BXIwji/Jinja2-2.7.1/egg-dist-tmp-wRAOlC<br />warning: no files found matching '' under directory 'custom_fixers'<br />warning: no previously-included files matching '' found under directory 'docs/_build'<br />warning: no previously-included files matching '.pyc' found under directory 'jinja2'<br />warning: no previously-included files matching '.pyc' found under directory 'docs'<br />warning: no previously-included files matching '.pyo' found under directory 'jinja2'<br />warning: no previously-included files matching '.pyo' found under directory 'docs'<br />Adding Jinja2 2.7.1 to easy-install.pth file<br />...................


登录后回复
 

与 Odoo 中文社区 的连接断开,我们正在尝试重连,请耐心等待