Odoo中文社区可以通过以下三个域名访问:shine-it.net , odoocn.org,odoo.net.cn

原论坛用户的基本信息和发帖这里都予以保留,请注意:原论坛用户无需重新注册新用户,但是您的密码需要重置

开发人员可以登录gitter讨论组: http://gitter.im/odoo-china/Talk, 需要github账号

如果您登录系统碰到问题,请在微信公众号留言:

编译和运行OPENERP 6.0.2遇到问题,请大家帮忙



  • 我下载了OpenERP 6.0.2 (OpenERP 6.0.1也有碰到同样的问题),当我编译运行的时候,碰到了几个问题,请大家帮忙:

    1. OpenERP web client中文出现乱码,经过一番研究,发现是在_expose.py的方法def expose(format='html', template=None, content_type=None, allow_json=False, methods=None, mark_only=False) 里面的两行代码改了之后可以正常显示中文:

    代码1:
    #return render_template(_template, res).encode("utf-8")  #原来的代码
    return render_template(template, res)    #改后能正常显示的代码

    代码2:
    # return unicode(res).encode("utf-8") #原来的代码
    return unicode(res) #改后能正常显示的代码

    我写了个小的例子来重现这个问题,发现unicode的中文能正常在web页面里面显示,encode成utf-8 (encode("utf-8"))后,在页面里面就是乱码,不知道什么原因,安装的6.0.2是可以正常显示的。

    2. 我从源代码运行OpenERP的时候,系统报下面的编译错误:
      File "D:\Training\openerp\open-server\bin\osv\orm.py", line 57, in <module>
        import fields
      File "D:\Training\openerp\open-server\bin\osv\fields.py", line 39, in <module>
        from psycopg2 import tz
      File "C:\Python27\lib\site-packages\psycopg2_init
    .py", line 72, in <module>
        from psycopg2._psycopg import BINARY, NUMBER, STRING, DATETIME, ROWID
    ImportError: DLL load failed: The operating system cannot run %1.

    我用easy_install安装的最新版的psycopg2,好像是2.4.1,我检查了我的VC++的版本,是VC++ 2008, python是2.7.1,也是VC++ 2008编译的。也尝试过下载psycopg2的源代码,自己编译,也碰到同样的问题。有人知道这是什么原因吗?



  • 我下载了OpenERP 6.0.2 (OpenERP 6.0.1也有碰到同样的问题),当我编译运行的时候,碰到了几个问题,请大家帮忙:

    1. OpenERP web client中文出现乱码,经过一番研究,发现是在_expose.py的方法def expose(format='html', template=None, content_type=None, allow_json=False, methods=None, mark_only=False) 里面的两行代码改了之后可以正常显示中文:

    代码1:
    #return render_template(_template, res).encode("utf-8")  #原来的代码
    return render_template(template, res)    #改后能正常显示的代码

    代码2:
    # return unicode(res).encode("utf-8") #原来的代码
    return unicode(res) #改后能正常显示的代码

    我写了个小的例子来重现这个问题,发现unicode的中文能正常在web页面里面显示,encode成utf-8 (encode("utf-8"))后,在页面里面就是乱码,不知道什么原因,安装的6.0.2是可以正常显示的。

    2. 我从源代码运行OpenERP的时候,系统报下面的编译错误:
      File "D:\Training\openerp\open-server\bin\osv\orm.py", line 57, in <module>
        import fields
      File "D:\Training\openerp\open-server\bin\osv\fields.py", line 39, in <module>
        from psycopg2 import tz
      File "C:\Python27\lib\site-packages\psycopg2_init
    .py", line 72, in <module>
        from psycopg2._psycopg import BINARY, NUMBER, STRING, DATETIME, ROWID
    ImportError: DLL load failed: The operating system cannot run %1.

    我用easy_install安装的最新版的psycopg2,好像是2.4.1,我检查了我的VC++的版本,是VC++ 2008, python是2.7.1,也是VC++ 2008编译的。也尝试过下载psycopg2的源代码,自己编译,也碰到同样的问题。有人知道这是什么原因吗?



  • 编译 psycopg2 的时候 成功了吗?



  • Linux不用编译,直接运行就可以了,所以没有遇到这样的问题。


登录后回复
 

与 Odoo 中文社区 的连接断开,我们正在尝试重连,请耐心等待