Odoo中文社区可以通过以下三个域名访问:shine-it.net , odoocn.org,odoo.net.cn

原论坛用户的基本信息和发帖这里都予以保留,请注意:原论坛用户无需重新注册新用户,但是您的密码需要重置

开发人员可以登录gitter讨论组: http://gitter.im/odoo-china/Talk, 需要github账号

如果您登录系统碰到问题,请在微信公众号留言:

CentOS 6.5环境下能安装openerp-8.0dev-latest.tar.gz 吗?



  • 我参考这里的《Ubuntu Server12.04下 OpenERP 8.0的deb方式安装》一文,尝试嫁接到CentOS6.5下,好像有些依赖库没有源,最后启动oe8服务时报错。不知坛里有没有高人解决了CentOS下安装并运行oe8的问题?



  • 我参考这里的《Ubuntu Server12.04下 OpenERP 8.0的deb方式安装》一文,尝试嫁接到CentOS6.5下,好像有些依赖库没有源,最后启动oe8服务时报错。不知坛里有没有高人解决了CentOS下安装并运行oe8的问题?



  • 我参照OE7安装脚本在centos6.5上安装OE8, 一切正常啊, 主要是将postgresql-9.3数据库安装好, OE8就是解压后拷贝,增加openerp用户的目录权限,启动start.sh



  • 8的中文化有吗?基本模块u有吗?



  • 你说的green openerp 8吗? 要找源码安装的python2.7你是怎么解决的?<br /><br />centos 6.5也是python 2.6, 安装后或有少dict 之类的错误。求解答



  • [quote author=daishiju link=topic=16268.msg27627#msg27627 date=1394791249]<br />我参照OE7安装脚本在centos6.5上安装OE8, 一切正常啊, 主要是将postgresql-9.3数据库安装好, OE8就是解压后拷贝,增加openerp用户的目录权限,启动start.sh<br />[/quote]<br /><br />求安装过程,谢谢



  • 可以先把PYTHON2.6升级到2.7 ,当然现在CENTOS 7 自带PYTHON2.7 你也可以试一下。<br /><br />升级PYTHON******************<br />python  -V    #查看PYthon版本#<br /><br />wget https://www.python.org/ftp/python/2.7.6/Python-2.7.6.tgz    <br /><br />tar -jxvf Python-2.7.6.tgz    <br /><br />cd Python-2.7.6<br /><br />./configure  <br /><br />make all            <br /><br />make install  <br /><br />make clean  <br /><br />make distclean    <br /><br />mv /usr/bin/python  /usr/bin/python2.6.6 #老版本 改名 <br /><br />ln -s /usr/local/bin/python2.7 /usr/bin/python #链接 新版本 <br /><br />编译/usr/bin/yum  文件  指向老的python



  • 我按您的方式升级python2.7.6之后,安装<br />[root@n6-openerp2 openerp-8.0-b0e4ff2]# python setup.py  install<br />但是执行openerp-server提示错误<br />  File "/usr/local/lib/python2.7/site-packages/openerp-8.0_b0e4ff2-py2.7.egg/openerp/osv/osv.py", line 23, in <module><br />    from .orm import Model, TransientModel, AbstractModel<br />  File "/usr/local/lib/python2.7/site-packages/openerp-8.0_b0e4ff2-py2.7.egg/openerp/osv/orm.py", line 2, in <module><br />    from lxml import etree<br />  File "lxml.etree.pyx", line 161, in init lxml.etree (src/lxml/lxml.etree.c:198989)<br />[color=red][b]TypeError: encode() argument 1 must be string without null bytes, not unicode[/b][/color]<br /><br />您那边没有遇到吗?



  • 公布一下,已经成功,系统时普华服务器操作系统3.0(i-Soft Server OS 3.0),相当于CentOS6.3。<br />关于python必须是2.7以上,pg必须9.3以上<br />python我找了两个方法,1、google找到了2.7.3的rpm包。其他插件有rpm有源码安装的。2、2.7.6源码安装,然后pip安装所有的包。<br />pg从网上找到9.3的rpm。<br />已经可以正常添加crm。正常运行。<br />fan3838@QQ . com可以交流


登录后回复
 

与 Odoo 中文社区 的连接断开,我们正在尝试重连,请耐心等待