Odoo中文社区可以通过以下三个域名访问:shine-it.net , odoocn.org,odoo.net.cn

原论坛用户的基本信息和发帖这里都予以保留,请注意:原论坛用户无需重新注册新用户,但是您的密码需要重置

开发人员可以登录gitter讨论组: http://gitter.im/odoo-china/Talk, 需要github账号

如果您登录系统碰到问题,请在微信公众号留言:

有没有在Red hat上成功安装过的大侠啊?



  • 有没有在Red hat上成功安装过的大侠啊?我用的是HOSTMONSTER的主机,也成功安装上python2.5了,可是缺少reportlab,pychart,pydot,libxml2等几个库。
    用easy_install-2.5 reportlab安装reportlab安装到一半就出错了。
    easy_install-2.5 pychart或easy_install-2.5 libxml2等,直接提示没有找到这个名字的包。



  • 有没有在Red hat上成功安装过的大侠啊?我用的是HOSTMONSTER的主机,也成功安装上python2.5了,可是缺少reportlab,pychart,pydot,libxml2等几个库。
    用easy_install-2.5 reportlab安装reportlab安装到一半就出错了。
    easy_install-2.5 pychart或easy_install-2.5 libxml2等,直接提示没有找到这个名字的包。


  • 管理员

    我們这里没有什么大侠和规矩,但是有一些小共识。比如:同样内容的帖子只发一次。感谢你会与我們有同样的共识。

    用easy_install安装不成功可能是缺少一些需要的库。你可以试试用rpm安装包安装。[url=rpmfind.net/linux/RPM/]http://rpmfind.net/linux/RPM/[/url] 这里可能有你要的东西。

    [[i] 本帖最后由 digitalsatori 于 2009-6-17 09:09 编辑 [/i]]



  • 见 [url]shine-it.net/tinyerp/viewthread.php?tid=520&extra=page%3D1[/url]

    centos跟redhat几乎一样



  • 我是在Hostmonster的主机上安的,没有RPM的安装权限,现在只有libxml2-2.6.27.tar.gz,libxslt-1.1.23.tar.gz这两个模块没有安装上。因为libxslt在configure的时候报错说,已经在系统里发现了更低版本的libxslt,我没有RPM卸载软件的权限,应该怎么办?


  • 管理员

    要编译安装libxml2 libxslt的[b]python binding[/b]前提是,你的系统已经安装了libxml2和libxslt这些C语言的解析库。

    其实你付费给HOSTMONSTER,他们应该负责帮助你解决这些问题啊。



  • 我给人家说了可以另外付费,可是人家说不提供这种服务,还说我可以考虑换一个主机提供商!
    现在我已经安装上了,但是python2.5 openerp-server.py的时候提示
    ERROR: pythonic binding for the libxml2 and libxslt libraries is missing
    ERROR: Try to install python-lxml package
    lxml包我使用easy_install-2.5安装上了,而且在lib/python2.5/sitepackages下面有lxml-2.2.1-py2.5-linux-x86_64.egg。我在python2.5下面import lxml,libxml2都没有报错。
    是不是因为我安装的libxml2,libxslt是在特定目录下,要设什么环境变量啊?


  • 管理员

    按你说的,能import的话就应该没有问题了。
    不成功的原因会不会是默认的python的版本不是2.5,你需要用比如python2.5 openerp-server.py来运行。



  • 我用的就是python2.5 openerp-server.py啊!快疯了!



  • 只有自己试了,我在webfaction上安装开始也不成功,后来想卸掉 openerp重新装也不行,
    后来没有办法只有把源文件上传用 python openerp-server.py 来运行。
    我搞了一个星期多才可以运行,要有耐心,呵呵。



  • redhat自带的python是什么版本



  • RED HAT as3的服务器,带的是python2.3。有一个什么虚拟环境安装的怎么用?用那个行不?不知道那个虚拟怎么用?在论坛上见了,可是没有具体的步骤。哪位知道啊?请教一下。


  • 管理员

    你可以
    [code]easy_install virtualenv[/code]
    安装完成后,可以使用比如:
    [code]virtualenv --no-site-package myproject[/code]
    其中--no-site-package是可选项,表示不使用当前python环境中site-package中的模块
    这样就会在当前目录下创建一个myproject的目录。
    [quote]cd myproject
    source bin/activate[/quote]
    当你运行了上述的命令后,注意提示符的改变。这时表示你已经进入这个python的虚拟环境了,这个环境与全局的python环境是相对独立的。以后你用python setup.py或easy_install 安装模块都会直接安装到这个虚拟环境中。好处是如果你有几个项目并且每个项目都有不同的包依赖,你就可以建立几个虚拟环境,各个虚拟环境中的python包都相互独立,不会有冲突。
    要退出虚拟环境,运行:
    [code]deactivate[/code]


登录后回复
 

与 Odoo 中文社区 的连接断开,我们正在尝试重连,请耐心等待