Odoo中文社区可以通过以下三个域名访问:shine-it.net , odoocn.org,odoo.net.cn

原论坛用户的基本信息和发帖这里都予以保留,请注意:原论坛用户无需重新注册新用户,但是您的密码需要重置

开发人员可以登录gitter讨论组: http://gitter.im/odoo-china/Talk, 需要github账号

如果您登录系统碰到问题,请在微信公众号留言:

在virtualenv 中安装odoo11问题



  • 问题1就是直接在ubuntu中进行安装的。
    问题2时在virtualenv 中进行安装的。

    问题1:在安装依赖时,libssl1.0-dev 提示安装不成功,如下图。但是,
    0_1517542724145_截图.png

    如果单独安装sudo apt-get install libssl-dev,可以安装成功的。再次进行上图的安装还是上面的提示的。好像没解决问题
    0_1517543278990_ddb891b1-ba2d-4a90-890f-bfd5bd80f22f-图片.png

    问题2:后续安装odoo11中的requirements.txt会提示错误,是否跟上面安装不成功有关呢?怎么解决?
    0_1517542762789_截图 (1).png
    0_1517542768991_截图 (2).png


  • 管理员

    第一个问题已然解决,第二个问题是在编译Python库包时没有找到Python头文件,
    试试:

    apt-get install python3-dev
    


  • @digitalsatori
    安装了python3-dev,还是报错如下:
    0_1517799166309_1.png

    0_1517799192426_22.png


登录后回复
 

与 Odoo 中文社区 的连接断开,我们正在尝试重连,请耐心等待