Odoo中文社区可以通过以下三个域名访问:shine-it.net , odoocn.org,odoo.net.cn

原论坛用户的基本信息和发帖这里都予以保留,请注意:原论坛用户无需重新注册新用户,但是您的密码需要重置

开发人员可以登录gitter讨论组: http://gitter.im/odoo-china/Talk, 需要github账号

如果您登录系统碰到问题,请在微信公众号留言:

Debian 5.x下,apache+ssl proxy的配置



  • 启用ssl模块:
    [code]a2enmod ssl[/code]

    生成证书:
    [code]apache2openssl req -x509 -newkey rsa:1024 -keyout apache.pem -out apache.pem -nodes -days 9999[/code]
    输入证书信息若干...

    或者可以这样:
    openssl req $@ -new -x509 -days 3650 -nodes -out /etc/apache2/apache.pem -keyout /etc/apache2/apache.pem

    copy出一个ssl的配置(懒的写site配置文件了):
    [code]cp /etc/apache2/sites-enabled/000-default /etc/apache2/sites-enabled/000-ssl[/code]

    vim之, 修改端口为[size=99px]ServerSignature On
    SSLEngine On
    SSLCertificateFile /your-path/apache.pem [/code]

    重启:
    [code]/etc/init.d/apache2 restart[/code]

    试访问:
    <!-- m -->[url=https://you-ip]https://you-ip[/url]<!-- m -->


    设置proxy:
    启用两个模块(必须的):
    [code]
    a2enmod proxy
    a2enmod proxy_http
    [/code]

    编辑刚才的文件:
    [code]vim sitess-enabled/000-ssl[/code]
    添加:
    [code]
    ProxyPass / localhost:8080/
    ProxyPassReverse / localhost:8080/
    [/code]

    允许访问:
    [code]vim /etc/apache2/mods-available/proxy.conf[/code]
    修改为:
    [code]Allow from all[/code]
    重启apache2
    [code]/etc/init.d/apache2 restart[/code]

    访问:
    <!-- m -->[url=https://your-ip]https://your-ip[/url]<!-- m -->

    the end.

    [[i] 本帖最后由 d_yang 于 2010-4-15 11:19 编辑 [/i]]



  • 启用ssl模块:
    [code]a2enmod ssl[/code]

    生成证书:
    [code]apache2openssl req -x509 -newkey rsa:1024 -keyout apache.pem -out apache.pem -nodes -days 9999[/code]
    输入证书信息若干...

    或者可以这样:
    openssl req $@ -new -x509 -days 3650 -nodes -out /etc/apache2/apache.pem -keyout /etc/apache2/apache.pem

    copy出一个ssl的配置(懒的写site配置文件了):
    [code]cp /etc/apache2/sites-enabled/000-default /etc/apache2/sites-enabled/000-ssl[/code]

    vim之, 修改端口为[size=99px]ServerSignature On
    SSLEngine On
    SSLCertificateFile /your-path/apache.pem [/code]

    重启:
    [code]/etc/init.d/apache2 restart[/code]

    试访问:
    <!-- m -->[url=https://you-ip]https://you-ip[/url]<!-- m -->


    设置proxy:
    启用两个模块(必须的):
    [code]
    a2enmod proxy
    a2enmod proxy_http
    [/code]

    编辑刚才的文件:
    [code]vim sitess-enabled/000-ssl[/code]
    添加:
    [code]
    ProxyPass / localhost:8080/
    ProxyPassReverse / localhost:8080/
    [/code]

    允许访问:
    [code]vim /etc/apache2/mods-available/proxy.conf[/code]
    修改为:
    [code]Allow from all[/code]
    重启apache2
    [code]/etc/init.d/apache2 restart[/code]

    访问:
    <!-- m -->[url=https://your-ip]https://your-ip[/url]<!-- m -->

    the end.

    [[i] 本帖最后由 d_yang 于 2010-4-15 11:19 编辑 [/i]]



  • 嗯... 不错....


登录后回复
 

与 Odoo 中文社区 的连接断开,我们正在尝试重连,请耐心等待