Odoo中文社区可以通过以下三个域名访问:shine-it.net , odoocn.org,odoo.net.cn

原论坛用户的基本信息和发帖这里都予以保留,请注意:原论坛用户无需重新注册新用户,但是您的密码需要重置

开发人员可以登录gitter讨论组: http://gitter.im/odoo-china/Talk, 需要github账号

如果您登录系统碰到问题,请在微信公众号留言:

新人求助openerp 5.0.12 无法安装sale销售模块



  • 这几天刚刚看到这个系统,想安装试试看,可是在建账套时发现,无法安装sale模块。在这里求教各位大侠帮忙看下,
    错误代码如下:
    Environment Information :
    System : Windows-32bit
    OS Name : nt
    Operating System Release :
    Operating System Version : 32bit
    Operating System Architecture : 32bit
    Operating System Locale : zh_CN.cp936
    Python Version : 2.5.2
    OpenERP-Client Version : 5.0.12
    Last revision No. & ID :Bazaar Package not Found !Traceback (most recent call last):
      File "netsvc.pyo", line 247, in dispatch
      File "netsvc.pyo", line 76, in call
      File "service\web_services.pyo", line 633, in execute
      File "service\web_services.pyo", line 613, in execute
      File "wizard_init
    .pyo", line 178, in execute
      File "wizard_init_.pyo", line 73, in execute_cr
      File "D:\OpenERP\Server\addons\base\module\wizard\wizard_module_upgrade.py", line 92, in upgrade_module
      File "pooler.pyo", line 62, in restart_pool
      File "pooler.pyo", line 40, in get_db_and_pool
      File "addons_init
    .pyo", line 741, in load_modules
      File "addons_init_.pyo", line 623, in load_module_graph
      File "tools\convert.pyo", line 849, in convert_csv_import
      File "osv\orm.pyo", line 860, in import_data
      File "osv\orm.pyo", line 689, in process_liness
    ValueError: No references to sale.group_sale_user



  • 这几天刚刚看到这个系统,想安装试试看,可是在建账套时发现,无法安装sale模块。在这里求教各位大侠帮忙看下,
    错误代码如下:
    Environment Information :
    System : Windows-32bit
    OS Name : nt
    Operating System Release :
    Operating System Version : 32bit
    Operating System Architecture : 32bit
    Operating System Locale : zh_CN.cp936
    Python Version : 2.5.2
    OpenERP-Client Version : 5.0.12
    Last revision No. & ID :Bazaar Package not Found !Traceback (most recent call last):
      File "netsvc.pyo", line 247, in dispatch
      File "netsvc.pyo", line 76, in call
      File "service\web_services.pyo", line 633, in execute
      File "service\web_services.pyo", line 613, in execute
      File "wizard_init
    .pyo", line 178, in execute
      File "wizard_init_.pyo", line 73, in execute_cr
      File "D:\OpenERP\Server\addons\base\module\wizard\wizard_module_upgrade.py", line 92, in upgrade_module
      File "pooler.pyo", line 62, in restart_pool
      File "pooler.pyo", line 40, in get_db_and_pool
      File "addons_init
    .pyo", line 741, in load_modules
      File "addons_init_.pyo", line 623, in load_module_graph
      File "tools\convert.pyo", line 849, in convert_csv_import
      File "osv\orm.pyo", line 860, in import_data
      File "osv\orm.pyo", line 689, in process_liness
    ValueError: No references to sale.group_sale_user



  • 呵呵. 新版的 5.0.12 是有这个安装问题.  我BUG报告了. 但很多人说没有问题. 我反复试偶尔也存在.  黑桃J也遇到这个问题了.

    我建议你 下载 5.0.6 这个版本.. .至少, 我测试过, 没有安装问题

    附下载地址:
    http://www.openerp.com/download/old/openerp-allinone-setup-5.0.6.exe



  • 5.0.12没有问题的, 有可能是你以前装过老版本的, 并且没有更新.openerp_serverrc里的addons_path导致的吧。



  • 多谢各位,这问题找到原因了。是因为我在创建账套的时候选择了安装演示数据造成的,



  • 我在 5.0.12 版中,安装不了sale等模块,打开modules界面,只能显示已安装的模块,无论怎么查找,都不能出现其它模块,是怎么回事呢,有没有人遇到呢,以前在5.0.6这个版本中是没有这个问题的,有人知道吗?

    环境上我选的中国会计,没有装演示数据。



  • 所以, 综上所述. 不建议使用 5.0.12 的安装版本. 可以使用 5.0.6 的版本, 然后 手头更新 server 里面的代码.

    一般只需要把  5.0.12 的 addons 以及 bin 下面的源码更新到 liberary.zip (for windows版本) 中. 主相当于是最新版的 server 了.


登录后回复
 

与 Odoo 中文社区 的连接断开,我们正在尝试重连,请耐心等待