Odoo中文社区可以通过以下两个域名访问:shine-it.net , odoo.net.cn

由于系统升迁的原因,本论坛部分较早期的内容存在格式和链接损坏失效的问题,并非本论坛系统本身的缺陷,望谅解

本社区没有维护任何QQ群讨论组,任何与本社区同名的QQ群讨论组的言论与本社区无关!

开发人员可以登录gitter讨论组: http://gitter.im/odoo-china/Talk, 需要github账号

如果您登录系统碰到问题,请在微信公众号留言:

OpenERP 6.0.2 All In One 备份问题



  • all in one liberary.zip 文件. 替换为附件[attachurl=1]中的文件, 并重启 server

    主要是  service\web_service.py    tools\misc.py  文件..

    另一个重要的地方是 openerp-server.conf 文件中,  pg_path 一定要正确.



  • 困扰了很久的问题,终于有了解答,晚上回家试试。



  • 我用6.0.3 All in one也有同样的问题。
    无法backup and restore
    不知有没有解决方法。



  • 请教SHELL“另一个重要的地方是 openerp-server.conf 文件中,  pg_path 一定要正确.”,我的是pg_path = None,是改为.....?



  • 改为你的 pg_dump pg_restore 的路径...

    如:

    pg_path = C:\Program File\OpenERP\PostgreSQL\bin\



  • [quote author=mrshelly link=topic=2537.msg8600#msg8600 date=1315299415]
    如:

    pg_path = C:\Program File\OpenERP\PostgreSQL\bin<br />[/quote]


    我更改openerp-server.conf和替换两个文件后,数据库登录不上去,创建数据库也出错,如楼下图,请SHELLY看看:我的是6.0.3的ALLINONE,是不是不适用6.0.3?



  • [quote author=mrshelly link=topic=2537.msg8600#msg8600 date=1315299415]
    改为你的 pg_dump pg_restore 的路径...

    如:

    pg_path = C:\Program File\OpenERP\PostgreSQL\bin<br />[/quote]

    谢谢SHEELY,快照然后再试,成功了(备份与恢复),应该是上次操作有误。 🙂 🙂



  • Congratulations



  • 非常感谢!弄了很久了



  • 我使用 OpenERP 6.0.2 All-In -One,碰到同样的问题。 采用下面这种方法,问题解决了。致谢!

    [quote author=mrshelly link=topic=2537.msg8383#msg8383 date=1311227353]
    all in one liberary.zip 文件. 替换为附件[attachurl=1]中的文件, 并重启 server

    主要是  service\web_service.py    tools\misc.py  文件..

    另一个重要的地方是 openerp-server.conf 文件中,  pg_path 一定要正确.
    [/quote]



  • 搞定~~~谢谢哈


Log in to reply