Odoo中文社区可以通过以下两个域名访问:shine-it.net , odoo.net.cn

由于系统升迁的原因,本论坛部分较早期的内容存在格式和链接损坏失效的问题,并非本论坛系统本身的缺陷,望谅解

本社区没有维护任何QQ群讨论组,任何与本社区同名的QQ群讨论组的言论与本社区无关!

开发人员可以登录gitter讨论组: http://gitter.im/odoo-china/Talk, 需要github账号

如果您登录系统碰到问题,请在微信公众号留言:

CentOS6.2+OpenERP6.1 打印报价单出错:decoder zip not available



  • decoder zip not available

    (<type 'exceptions.IOError'>, IOError('decoder zip not available',), <traceback object at 0xb270c5a4>)



  • 问题自己解决了,这是因为安装PIL-1.1.6导致的错误,错误如下:
    **************************************************************
    Failure in example: _info(Image.open("Images/lena.jpg"))
    from line #24 of selftest.testimage
    Exception raised:
    Traceback (most recent call last):
      File "./doctest.py", line 499, in _run_examples_inner
        exec compile(source, "<string>", "single") in globs
      File "<string>", line 1, in <module>
      File "./selftest.py", line 22, in _info
        im.load()
      File "PIL/ImageFile.py", line 180, in load
        d = Image._getdecoder(self.mode, d, a, self.decoderconfig)
      File "PIL/Image.py", line 375, in _getdecoder
        raise IOError("decoder %s not available" % decoder_name)
    IOError: decoder jpeg not available
    1 items had failures:
      1 of  57 in selftest.testimage
    Test Failed 1 failures.
    1 tests of 57 failed.

    后来直接去安装了个 PIL-1.1.7,完美解决!!!



  • OK. 那就是OE 仅支持 PIL >= 1.1.7  版本的了吗?

    谢谢分享...


Log in to reply