Odoo中文社区可以通过以下两个域名访问:shine-it.net , odoo.net.cn

由于系统升迁的原因,本论坛部分较早期的内容存在格式和链接损坏失效的问题,并非本论坛系统本身的缺陷,望谅解

本社区没有维护任何QQ群讨论组,任何与本社区同名的QQ群讨论组的言论与本社区无关!

开发人员可以登录gitter讨论组: http://gitter.im/odoo-china/Talk, 需要github账号

如果您登录系统碰到问题,请在微信公众号留言:

Oe6.1在打印成本构成时报错。



  • 错误如下,不知何故?

    ascii
    %Y年%m月%d日 %H时%M分%S秒
    2
    3
    ordinal not in range(128)

    (<type 'exceptions.UnicodeEncodeError'>, UnicodeEncodeError('ascii', u'%Y\u5e74%m\u6708%d\u65e5 %H\u65f6%M\u5206%S\u79d2', 2, 3, 'ordinal not in range(128)'), <traceback object at 0x7fedb17103f8>)


  • 管理员

    这是OpenERP对带中文的日期格式的转码处理的一个bug,你可以用用下面的方法来绕过这个bug:
    点击  设置(Setting)---翻译(translations)----语言(Languages) 菜单
    在列表中点击打开:中文(zh_cn)语言项
    在中文语言表单中,改变日期格式为:%m/%d/%Y
    保存后就应该不会有报错了。



  • 问题解决,非常感谢!


Log in to reply