Odoo中文社区可以通过以下两个域名访问:shine-it.net , odoo.net.cn

由于系统升迁的原因,本论坛部分较早期的内容存在格式和链接损坏失效的问题,并非本论坛系统本身的缺陷,望谅解

本社区没有维护任何QQ群讨论组,任何与本社区同名的QQ群讨论组的言论与本社区无关!

开发人员可以登录gitter讨论组: http://gitter.im/odoo-china/Talk, 需要github账号

如果您登录系统碰到问题,请在微信公众号留言:

採購訂單key完後,按下列印詢價單及採購單,會出現錯誤



  • 目前我採購訂單key完後,按下列印詢價單及採購單,會出現如下錯誤,看不是很了解意思,可否麻煩幫我看一下這是何錯誤,以及該如何解決呢??

    🙂

    "ascii
    %Y年%m月%d日
    2
    3
    ordinal not in range(128)" while evaluating
    'formatLang(order_line.date_planned, date = True)'

    <type 'exceptions.ValueError'>,"ascii
    %Y年%m月%d日
    2
    3
    ordinal not in range(128)" while evaluating
    'formatLang(order_line.date_planned, date = True)',<traceback object at 0x7f566c603638>


  • 管理员

    這應該是OpenERP的的一個Bug,你可以嘗試這樣修改:
    [list type=decimal]
    [li]进入 Settings/Translations/Languages  [/li]
    [li]選擇你目前的語言(Eg.正體字)[/li]
    [li]把里面的 Date Format 由[b]%Y年%m月%d[/b]日改为[b]%Y/%m/%d[/b],意思就是讓時間格式不出現中文。同理建議Time Format也修改成[b]%I:%M:%S[/b][/li]
    [/list]



  • 不好意思,我卡在這個步驟

    可以請問這詳細路徑在那兒呢??是我在web頁面下改就ok了嗎??還是要到ubuntu下的某個資料夾內找資料改?

    若是,可否請問詳細的路徑或者是那一個資料夾內呢?

    把里面的 Date Format 由%Y年%m月%d日改为%Y/%m/%d,意思就是讓時間格式不出現中文。同理建議Time Format也修改成%I:%M:%S


  • 管理员

    web上面改就ok了.如图
    [attach=1]



  • 未有languages這個模組,難怪我找不到,

    不好意思,可否請問這個若要download及install的話…

    要選擇那一個名稱來update?


  • 管理员

    不是模組来的,你首先要确保你的用户是有Technical Features的权限。才能看到language菜单。



  • 原來如此,謝謝您的回覆~~~解決了!! 🙂


Log in to reply