Odoo中文社区可以通过以下两个域名访问:shine-it.net , odoo.net.cn

由于系统升迁的原因,本论坛部分较早期的内容存在格式和链接损坏失效的问题,并非本论坛系统本身的缺陷,望谅解

本社区没有维护任何QQ群讨论组,任何与本社区同名的QQ群讨论组的言论与本社区无关!

开发人员可以登录gitter讨论组: http://gitter.im/odoo-china/Talk, 需要github账号

如果您登录系统碰到问题,请在微信公众号留言:

Openerp 8.0 安装后, openerp-server-8.0 启动后自动停止



  • openerp 8.0  安装后, openerp-server-8.0 启动后自动停止

    用的是最新版本<br / [检测到链接无效,已移除]

    请哪位大侠支个招


  • 管理员

    请贴出openerp的server log



  • openerp 中没有找到相关的 log 文件,整个系统中没有找到 openerp-server.log

    在服务器的事件查看器中,有如下信息:(在win7 和 win2003 中均是这样的错误信息)
    --------------------------------------------------------
    事件类型: 错误
    事件来源: openerp-server-8.0
    事件种类: 无
    事件 ID: 3
    日期: 2014-09-15
    事件: 11:23:18
    用户: N/A
    计算机: MYSRVR
    描述:
    The instance's SvcRun() method failed
    Traceback (most recent call last):
      File "win32serviceutil.pyo", line 835, in SvcRun
      File "win32_service.pyo", line 42, in SvcDoRun
    SystemExit: 255
    %2: %3
    ---------------------------------------------



  • 我也碰到这个问题



  • 试试步科制作的绿色版:http://shine-it.net/index.php/topic,5811.0.html



  • 我也遇到同样问题

    postgresql-2014-09-22_102357.log

    2014-09-22 11:41:38 HKT 日志:  无效的启动包长度



  • 百度也查不到
    不知道是什么意思



  • 我也遇到了,windows服务里两个服务显示启动的,但是 localhost:8069就是打不开,500错误
    我是第一次装openerp,



  • 我又在家里的windows7上安装了下22号码的版本 正常。

    但是在xp下就是这个问题。



  • 我今天装了2014-9-24号的版本,也没有这个问题了
    估计这是14号版本的bug



  • [quote author=Joshua link=topic=16605.msg28975#msg28975 date=1410748140]
    请贴出openerp的server log
    [/quote]

    服务都无法启动,去哪里看日志!



  • WIN7 64 位
    今天装 odoo_8.0-20140924-000206.exe 
    依然 是  odoo-server  服务启动后自动停止



  • 下载最近25号的版本,也出现openerp-server-8.0 启动后自动停止。在win7和XP下遇到同样的问题。我试了各位说的各种版本,还是一样的问题。求救!



  • 我就是想问这个问题,我在window 8上安装的,原来安装的OE7还是好用的,以为有冲突,卸载OE7安装依然是这个问题。



  • 我同样的问题,试过buke的allinone绿色版8.0,官方allinone8.0-latest,官方allinone7.0-latest,都是同样的症状,家里(官方8.0-7.0)和公司机器(buke绿色allinone)都是。
    进入安装目录,cmd下手动启动openerp-server,显示出错信息如下:
    Traceback (most recent call last):
      File "openerp-server", line 2, in <module>
      File "C:\PROGRA~1\Odoo 8.0-20141015-000206\server.\openerp_init_.py", line
    78, in <module>
        import service
      File "C:\PROGRA~1\Odoo 8.0-20141015-000206\server.\openerp\service_init_.p
    y", line 27, in <module>
        import wsgi_server
      File "C:\PROGRA~1\Odoo 8.0-20141015-000206\server.\openerp\service\wsgi_serve
    r.py", line 46, in <module>
        import websrv_lib
      File "C:\PROGRA~1\Odoo 8.0-20141015-000206\server.\openerp\service\websrv_lib
    .py", line 37, in <module>
        from SimpleHTTPServer import SimpleHTTPRequestHandler
      File "SimpleHTTPServer.pyc", line 27, in <module>

      File "SimpleHTTPServer.pyc", line 208, in SimpleHTTPRequestHandler

      File "mimetypes.pyc", line 358, in init

      File "mimetypes.pyc", line 258, in read_windows_registry
        --extension / -e  -- guess extension instead of type
      File "mimetypes.pyc", line 249, in enum_types

    UnicodeDecodeError: 'ascii' codec can't decode byte 0xb0 in position 1: ordinal
    not in range(128)

    事件查看器中错误提示如楼主所说。非常莫名其妙
    ==========
    更新:
    10-16 今早到公司,用昨晚下载的openerp-allinone-setup-7.0-20140622-231040(大小72m)安装,成功启动。昨晚家里安装用的是openerp_7.0-latest(122m).都是官方的。



  • 解决:
    参见我的发问。感谢mrshelly点拨。



  • 你好,请问这个问题怎么解决的呢?



  • 我的windows2003 32bit安装官方的odoo_8.0-latest.exe也是报这个错。
    The instance's SvcRun() method failed
    Traceback (most recent call last):
      File "win32serviceutil.pyo", line 835, in SvcRun
      File "win32_service.pyo", line 42, in SvcDoRun
    SystemExit: 255
    %2: %3



  • 遇到同样问题,求解。


Log in to reply