Odoo中文社区可以通过以下两个域名访问:shine-it.net , odoo.net.cn

由于系统升迁的原因,本论坛部分较早期的内容存在格式和链接损坏失效的问题,并非本论坛系统本身的缺陷,望谅解

本社区没有维护任何QQ群讨论组,任何与本社区同名的QQ群讨论组的言论与本社区无关!

开发人员可以登录gitter讨论组: http://gitter.im/odoo-china/Talk, 需要github账号

如果您登录系统碰到问题,请在微信公众号留言:

用open-client.exe登陆提示Assertion failed错误



  • 这两天刚接触openerp,刚装时好像没什么,正研究着,前天晚上,登陆就提示这个,
    Microsoft Visual C++ Runtime Library
    Assertion failed!
    Program: C:openerp allinoneclientopenerp-client.exe
    file: CXXcxx_extensions.cxx
    line:1187
    后面还有信息,就不打完了.
    5.06
    5.05都是这样.在两台电脑上都是这样,家里的,办公的.
    不知是怎么回事.望那位朋友能帮忙解决.
    不然想学着试用,实施,都法了.
    [attach]230[/attach]
    附上log文件,做成了压缩包,好上传.
    [attach]231[/attach]
    另外,我刚看了一下,安装的是allinone包,所以用的应该是安装路径里的MSVCP71.DLL

    [[i] 本帖最后由 riguang 于 2009-10-17 18:35 编辑 [/i]]


  • 管理员

    可能是你系统自带的msvcp运行库有问题或版本不匹配。运行库的名字为msvcpXX.dll,(XX为不同的版本) 到其他电脑或网上下载并替换系统中的同名文件,多数能解决问题。



  • 哦.多谢版大
    我刚搜了一下windows目录,版本有50/60/71/0/90
    要替换哪个呢?


  • 管理员

    你的出错信息中有提到版本吗?
    你可以试试安装这个包:
    download.microsoft.com/download/5/2/1/5212066c-5f48-4b16-a059-ed84b505a65d/vcredist_x86.exe



  • 前面试过了.不行.出错信息我已经截图了.



  • 我大约的总结了一下,每次装好后,刚开始是没有什么问题的.登陆后,随意的点击,装些需要的模块,然后退出就会提示错误,告诉说错误保存在openerp-client.exe.log里,点击client.exe,然后想登陆的时候,就出ASSERTION FAILED了,可能是这样.附上log内容



  • 用web好像没这么多问题.client.exe登陆不上,提示出错的套帐,用web就可以,
    套帐出错后,client.exe还可以再新建,我一般选service profile ,语言选中文,不配置,弄好后,装些常用的模块(比如销售)后随意点击(一般是点销售),又出错.

    [[i] 本帖最后由 riguang 于 2009-10-17 18:55 编辑 [/i]]


  • 管理员

    看了一下你的log文件,里面只有一类错误:UnicodeDecodeError, 这个错误与我几个月前报告的一个bug相关: shine-it.net/viewthread.php?tid=529&extra=page%3D1

    因为你的openerp服务器安装在中文windows上,其返回的服务器所在时区的信息来自中文windows,其内容是中文,客户端程序不但不能解析服务器所在的时区,而且面对中文内容还出现了解码错误。

    在GTK客户端中将时区设置为空,试试。

    不过,我不能确定这个log中的错误与你之前反应的Assertion error是不是有关系,google 了一下好象,你之前提到的错误与matplotlib有关。是不是在openerp中显示图表的时候才会有那样的错误?



  • 谢谢回复,关于assertion failed出现的顺序如下,是在5.05或5.06版本下,我装好了软件,设好套帐,选完profile(service),然后再加装销售模块,pos模块后,开始点击销售,浏览单据,再点关闭时,多数会提示UnicodeDecodeError,然后退出了,再登陆,就提示assertion failed,这两个错误提示不知有没有必然的联系,但顺序应该就是这样.
    然后我昨天在家里又试了5.0.1,还没出错.今天在办公这里试试看再说.



  • 装了5.01,选了重庆时区,香港时区,也出现了unicode error,看来这是版版说的已知bug,
    而我报的assertion问题,目前还没有出现.

    [[i] 本帖最后由 riguang 于 2009-10-18 14:25 编辑 [/i]]



  • 难得的 VCRT bug



  • 我也试过发生这个错误 被我按着忽略掉了



  • oldrev说的是assertion failed难得吗?请问有解决的办法吗



  • 是不是用ghost光盘安装的系统?


Log in to reply