Odoo中文社区可以通过以下两个域名访问:shine-it.net , odoo.net.cn

原论坛用户的基本信息和发帖这里都予以保留,请注意:原论坛用户无需重新注册新用户,但是您的密码需要重置

开发人员可以登录gitter讨论组: http://gitter.im/odoo-china/Talk, 需要github账号

如果您登录系统碰到问题,请在微信公众号留言:

求助:OE AllInOne 6 WEB问题



  • 成功安装OE AllInOne 6,本机IP:192.168.1.88 在本机用http://192.168.1.88:8080可以正常打开登录,在局域网其他电脑就打不开,这是为什么呢?<br />另外如果想把端口改成80要怎么修改呢?<br />谢谢!



  • 在你的本机的防火墙上允许 8080 端口即可.(或者你禁用掉windows 的防火墙)<br /><br />要修改端口. <br />进到 你的 OpenERP All In One 的 Web 文件夹中的 conf 文件夹 <br />用文本编辑软件打开openerp-web.cfg 文件.<br /><br />找到<br />

    <br /><br />server.socket_host = &quot;0.0.0.0&quot;<br />server.socket_port = 8080<br /><br />
    

    <br /><br />其中<br /><br />server.socket_port = 8080<br />的8080 就是你要修改的端口.<br /><br />修改后, 重启你的 All In One 服务( PostgreSQL 服务,  OpenERP server 服务,  OpenERP Web 服务), 不知道怎么启动服务的话, 重启你的电脑也可以.<br />



  • 重装XP系统,修改了端口,重启电脑,http://192.168.1.88:80还是打不开,http://192.168.1.88:8080反倒能打开,这就奇怪了<br /><br />

    <br />[global]<br />server.environment = &quot;development&quot;<br /><br /># Some server parameters that you may want to tweak<br />server.socket_host = &quot;0.0.0.0&quot;<br />server.socket_port = 80<br /><br /># Sets the number of threads the server uses<br />server.thread_pool = 10<br /><br />tools.sessions.on = True<br />tools.sessions.persistent = False<br /><br /># Simple code profiling<br />server.profile_on = False<br />server.profile_dir = &quot;profile&quot;<br /><br /># if this is part of a larger site, you can set the path<br /># to the TurboGears instance here<br />#server.webpath = &quot;&quot;<br /><br /># Set to True if you are deploying your App behind a proxy<br /># e.g. Apache using mod_proxy<br />#tools.proxy.on = True<br /><br /># If your proxy does not add the X-Forwarded-Host header, set<br /># the following to the *public* host url.<br />#tools.proxy.base = &#039;http://mydomain.com&#039;<br /><br /># logging<br />#log.access_file = &quot;/var/log/openerp-web/access.log&quot;<br />#log.error_file = &quot;/var/log/openerp-web/error.log&quot;<br />log.access_level = &quot;INFO&quot;<br />log.error_level = &quot;INFO&quot;<br /><br /># OpenERP tools<br />tools.nestedvars.on = True<br /># Set to false to disable CSRF checks<br />tools.csrf.on = True<br /><br /># OpenERP Server<br />openerp.server.host = &#039;localhost&#039;<br />openerp.server.port = &#039;8070&#039;<br />openerp.server.protocol = &#039;socket&#039;<br />openerp.server.timeout = 450<br /><br /># Web client settings<br />[openerp-web]<br /># filter dblists based on url pattern?<br /># NONE: No Filter<br /># EXACT: Exact Hostname<br /># UNDERSCORE: Hostname_<br /># BOTH: Exact Hostname or Hostname_<br /><br />dblist.filter = &#039;NONE&#039;<br /><br /># whether to show Databases button on Login screen or not<br />dbbutton.visible = True<br /><br /># will be applied on company logo<br />company.url = &#039;&#039;<br />
    


  • 另外发现IE8打不开,一直用的Firefox



  • 理论上不存在你所说的问题...<br /><br />IE8 我用过, 能正常访问..



  • 刚刚测试了一下 6.0.1 的 openerp-web.cfg 文件, 好象存在无效的问题. 估计又是什么BUG吧... 倒是很无语的BUG...<br /><br />然后 IE8你打不开, 可能是你没有输入 [检测到链接无效,已移除] 前缀的原因.<br /><br />我用IE8试了. 直接 localhost:8080 或者 ip:8080 是无效的.<br /><br />一定要输入 [检测到链接无效,已移除] 或者 [检测到链接无效,已移除] 才行.



  • 刚刚跟了一下 web client 的源码.<br /><br />发现, 6.0.1 的配置文件并不在 Web\conf\下.<br />而是在 Web\doc\openerp-web.cfg 下面, 测试了一下.<br />修改 Web\doc\openerp-web.cfg 文件是可以生效的.<br /><br />实在不懂 6.0.1 为什么要弄到 doc 文件夹下面...



  • 谢谢mrshelly,问题都解决了