Odoo中文社区可以通过以下两个域名访问:shine-it.net , odoo.net.cn

原论坛用户的基本信息和发帖这里都予以保留,请注意:原论坛用户无需重新注册新用户,但是您的密码需要重置

开发人员可以登录gitter讨论组: http://gitter.im/odoo-china/Talk, 需要github账号

如果您登录系统碰到问题,请在微信公众号留言:

在Fedora 15和Ubuntu 11.04上手动成功安装OpenERP 6



  • 注意,这里讨论的是手动安装,[color=red]不是使用yum或者apt-get安装[/color]。<br /><br />实现:<br />Postgresql 9.0.4源代码编译安装,配置启动服务。<br />Openerp-server web client 6.0.2 .tar.gz解压安装,配置启动服务<br /><br />有疑问的伙计可以共同探讨,希望能够有所帮助。



  • pg9, openerp可能不支持吧。记得有人报过unicode的问题


  • 管理员

    pg9应该是支持的,只是里面有个设置:[color=rgb(51, 51, 51)]bytea_output[/color]要改成‘escape',否则数据库名会是乱码。<br /><br />更正一下:应该是导入pg8的数据库时可能会出现数据库名乱码。



  • [quote author=wjfonhand link=topic=2420.msg8054#msg8054 date=1306998408]<br />pg9, openerp可能不支持吧。记得有人报过unicode的问题<br />[/quote]<br /><br />这个不支持体现在什么地方?<br />我现在的WEB就基本上无法正常运行,都是报UNICODE错误。在CLIENT偶尔有一个界面提示UNICODE错误。



  • [quote author=digitalsatori link=topic=2420.msg8056#msg8056 date=1306999487]<br />pg9应该是支持的,只是里面有个设置:[color=rgb(0, 0, 0)][/color][color=rgb(51, 51, 51)]bytea_output[/color]要改成‘escape',否则数据库名会是乱码。<br />[/quote]<br /><br />这个我要试一下,看看是否能够解决我之前遇到的UNICODE错误。<br /><br />-------------------更新<br />刚才看到bytea_output是与CLIENT CONNECTION有关的设置,如果是你所说的数据库名字乱码的话,我倒是没有出现。我的安转过程环境和过程是这样的:<br /><br />FEDORA/UBUNTU系统设置为中文;<br />下载POSTGRESQL 9.0.4,按照常规configuration,make编译安装好;<br />设置linux系统下的postgres账户和密码;在postgres账户下,运行initdb,指定数据库目录。<br />安装openerp,链接之后新建数据库(用的英文)之后就可以正常使用了。<br /><br />用pgAdmin3查看素有的数据库表的名字都是英文的。<br />Openerp Client使用基本正常,在Firefox 4下面基本上都是失败,而且都是unicode失败,我看提示比较多,暂时还没看。<br /><br />我是准备在公司应用一下,目前还在探索阶段。请大家多多指教!



  • 建议给个windows下的安装,我安装好了,但找不到数据库



  • [quote author=eremiter link=topic=2420.msg8098#msg8098 date=1307524483]<br />建议给个windows下的安装,我安装好了,但找不到数据库<br />[/quote]<br /><br />客户端连接失败通常是<br />1,数据库服务器连接失败,这个是由于POSTGRESQL[color=red]服务器[/color]的安装和配置不当造成的;<br />2,提示找不到数据库,这个说明POSTGRESQL[color=red]服务器[/color]已经可以使用了,但是没有建立OPENERP[color=red]数据库[/color]。<br /><br />通常在安装好之后都会提示找不到数据库,执行菜单中的“数据库”->“创建新数据库”就可以了。